What are the system requirements needed to take this course?

This course must be completed on a laptop or tablet that meets the following requirements: 

If you're using a computer:

  • We are compatible with all computers, but it is recommended that your computer is on the latest software for the best experience.
  • It needs to have a built-in webcam or one that can be hooked up to your computer. This is for your proctored final exam at the end of each course.
  • For your proctored final exam, you may not use a Chrome Book! 
  • We recommend being on the most up-to-date version of your Internet browser for the best experience. Internet Explorer is an extremely outdated software, so please use any of the other recommended browsers in this list:
    • Google Chrome
    • Mozilla Firefox
    •  Safari
    •  Opera
    •  Microsoft Edge

If you're using an iPad:

  • iOS software versions 9.3 and up
  • The oldest compatible iPad is an iPad 2 on iOS 9.3.5

If you're using an Android Tablet: 

  • Compatible with Android OS software versions 4.4 and up

 

Was this article helpful?
3 out of 3 found this helpful

Articles in this section

Looking for technical assistance with our courses, or Examity?
Click to go to our Technical & Troubleshooting section!
Not finding your answer? Let us help!
Our Student Concierge is here for you 7 days a week!
Ready to be an #AceableAgent?
Click through to purchase the course that's right for you, and take the first steps towards launching your new career!